yarn list

列出已安装的包。

yarn list
yarn list

yarn list 命令模仿 Unix 列目录命令的预期行为。 Yarn 中的list命令列出当前工作文件夹所有的依赖,通过参考所有包管理器的元信息文件,包括项目的依赖

yarn list vx.x.x
├─ package-1@1.3.3
├─ package-2@5.0.9
│  └─ package-3@^2.1.0
└─ package-3@2.7.0
yarn list [--depth] [--pattern]

默认情况下,所有包和它们的依赖会被显示。 要限制依赖的深度,你可以给 list 命令添加一个标志 --depth 所需的深度。

yarn list --depth=0

记住,深度层级时从零索引的。

yarn list --pattern <pattern> 会根据模式标志会筛选出依赖列表。

示例:

yarn list --pattern gulp
yarn list --pattern "gulp|grunt"
yarn list --pattern "gulp|grunt" --depth=1