yarn outdated

Перевіряє, чи є застарілі пакети в залежностях.

yarn outdated

Виводить на екран версії всіх пакетів із залежностей. Це включає в себе інформацію з поточною встановленою версією, бажану версію основану на семантичній версійності, а також найсвіжішу доступну версію.

Наприклад, в вашому package.json є наступні залежності:

{
  "dependencies": {
    "underscore": "~1.6.0"
  },
  "devDependencies": {
    "lodash": "4.15.0"
  }
}

Результат виконаня команди має виглядати приблизно так:

yarn outdated
Package    Current Wanted Latest Package Type    URL
lodash     4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
underscore 1.6.0   1.6.0  1.8.3  dependencies    https://github.com/jashkenas/underscore#readme
✨  Done in 0.72s.
yarn outdated [package...]

Виведе на екран інформацію про версію однієї або багатьох залежностей.

Наприклад для package.json вказаному вище, ви маєте побачити наступний результат виконання команди:

yarn outdated lodash
Package Current Wanted Latest Package Type    URL
lodash  4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
✨  Done in 1.04s.