yarn upgrade-interactive

Bu, npm-check etkileşimli güncelleme moduna benzer. Eski paketleri güncellemek için kolay bir yol sağlar.

yarn upgrade-interactive [--latest]

The upgrade-interactive command takes the same parameters as, and functions the same as the base upgrade command. Bu komut, herhangi bir bir güncelleme yapmadan önce güncel olmayan paketleri görüntüler ve kullanıcıya hangi paketlerin güncelleneceğini seçmesine izin verir. Yarn, yükselteceği versiyonu belirlerken package.json içerisindeki versiyon genişliğini dikkate alacak.

You can think of yarn upgrade-interactive as a combination of the yarn outdated and yarn upgrade [package...] commands. yarn outdated‘nın geçersiz paketleri görüntülediği ve yarn upgrade [package...]‘nin istenen paketleri güncelleyebildiği durumda, yarn upgrade-interactive aynı geçersiz listeyi görüntüler ve sizin o anda hangisini güncelleyeceğinizi seçmenizi ister.

--latest : Bu bayrak yarn’a package.json‘daki belirli sürüm aralıklarını reddetmesini ve onun yerine kayıt defterinde imlenmiş olan latest‘ı kullanmasını söyler.

[1/? Güncelleyeceğiniz paketleri seçin. (Seçmek için <space> , <a> hepsini değiştirmek için, <i> seçimi tersine çevirmek için)
 devDependencies
❯◯ autoprefixer      6.7.7  ❯  7.0.0          https://github.com/postcss/autoprefixer#readme
 ◯ webpack           2.4.1  ❯  2.5.1          https://github.com/webpack/webpack

 bağımlılıklar
 ◯ bull              2.2.6  ❯  3.0.0-alpha.3  https://github.com/OptimalBits/bull#readme
 ◯ fs-extra          3.0.0  ❯  3.0.1          https://github.com/jprichardson/node-fs-extra
 ◯ socket.io         1.7.3  ❯  1.7.4          https://github.com/socketio/socket.io#readme
 ◯ socket.io-client  1.7.3  ❯  1.7.4          https://github.com/Automattic/socket.io-client#readme