yarn upgrade

Belirtilen aralıkta paketleri en yeni sürüme yükseltir.

yarn güncelleme[package | package@tag | package@version | @scope/]... [--ignore-engines] [--pattern]

Bu komut, bağımlılıkları en son sürüme göre günceller. ` package.json </ 0> dosyasında belirtilen sürüm aralığı. yarn.lock </ 0> dosyası yeniden yaratılmalıdır.</p>

İsteğe bağlı olarak, bir veya daha fazla paket adı belirtilebilir. Paket adları belirtildiğinde yalnızca bu paketler güncellenecektir. Paket adı belirtilmediğinde, tüm bağımlılıklar yükseltilir.

[package]</ 0> : Belirtilen bir paket yalnızca bir ad olduğunda, bu paketin en son yamalı sürümü olarak güncellenecektir.</p>

[paket @ etiketi] </ 0> : Belirtilen bir paket bir etiket içerdiğinde belirtilen etiket güncellenecek. Tag adları proje yöneticileri tarafından seçilir, genellikle aktif olarak geliştirilen bir paketin deneysel veya uzun vadeli bir destek sürümünü yüklemek için bu komutu kullanırsınız. Seçtiğiniz etiket, package.json` dosyanızda görünen sürüm olacaktır. ` [paket @ sürümü] </ 0> : Belirtilen bir paket bir sürümü içerdiğinde belirtilen sürüme yükseltilecek. package.json </ 0> bağımlılık referans da bu belirtilen sürümle uyumlu olarak değiştirilecektir. Herhangi bir SemVer versiyon numarası ya da genişliği kullanabilirsiniz.</p>

--ignore-engines` Bu işaret makine kontrolünü geçmek için kullanılabilir. Örnekler: ```sh iplik yükseltme iplik yükseltme sol ped iplik yükseltme left-pad@^1.0.0 iplik yükseltme left-pad grunt iplik yükseltme @angular ``` `yarn upgrade --pattern ` şekil düzeniyle eşleşen tüm paketleri yükseltecek. Örnekler: ```sh iplik yükseltme-desen gulp iplik yükseltme sol-Pad --desen "gulp|grunt" iplik yükseltme --en son --"gulp-(maç|yeni)"deseni ``` ##### `yarn upgrade [package]... --latest|-L [--caret | --tilde | --exact] [--pattern]` ` yükseltme --latest </ 0> komutu, paketleri yükseltme </ 0> komutuyla aynı şekilde yükseltir, ancak package.json </ 0> 'da belirtilen sürüm aralığı yok sayılır. Bunun yerine en son ` etiketi tarafından belirtilen sürüm kullanılır (potansiyel olarak paketleri büyük sürümler arasında yükseltme). `package.json` dosyası en son versiyon genişliğini yansıtması için güncelleştirilecek. Varsayılan olarak, varolan aralığı belirticisi `paket.json` eğer bunlardan biri: ^, ~, <=, > veya tam bir sürümüdür. Aksi takdirde, bir işarete (^) dönüşecektir. Bayraklardan biri `--caret`, `--tilde` ya da `--exact` genişliği açıkça belirtmek için kullanılabilir. Örnekler: ```sh yarn yükseltme -- en son olan yarn yükseltme sol pad --en son olan yarn yükseltme sol pad grunt --en son olan --yaklaşık işareti ``` ##### `yarn güncelleştirme (--scope|-S) @scope [--latest] [--pattern]` `--scope @scope/` : bir scope belirtildiğinde, yalnızca bu scope ile başlayan paketler yükseltilecektir. Bir kapsam '@ ' ile başlamalıdır. `--en son` : `package.json` içerisinde belirtilen versiyon aralığını görmezden gelir. Bunun yerine ` en son ` etiketi tarafından belirtilen sürüm kullanılır (potansiyel olarak paketleri büyük sürümler arasında yükseltme). Örnekler: ```sh yarn güncelleştirme --scope @angular yarn güncelleştirme -S @angular ```