yarn outdated

Eski paket bağımlılıklarını kontrol eder.

yarn outdated

Tüm paket bağımlılıklarının sürüm bilgilerini listeler. Bu bilgi halihazırda yüklü olan sürümü, semver temelinde istenen sürümü ve en son kullanılabilir sürümü içerir.

Örneğin, package.json‘in aşağıdaki bağımlılıklar listelenmiştir:

{
  "dependencies": {
    "underscore": "~1.6.0"
  },
  "devDependencies": {
    "lodash": "4.15.0"
  }
}

Komut çalıştırması şu şekilde görünmelidir:

yarn outdated
Paket Mevcut Aranıyor En Son Paket Tipi URL'si
lodash 4.15.0 4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
altçizgi 1.6.0 1.6.0 1.8.3 bağımlılıkları https://github.com/jashkenas/underscore#readme
✨ 0.72s'de yapıldı.
yarn outdated [paket...]

Bir veya daha fazla paket bağımlılığı için sürüm bilgilerini listeler.

Örnek için paketi.json daha önce gösterilen, aşağıdaki görmelisiniz: bağımlılıklardan birini denetlerken çıktı:

yarn outdated lodash
Paket Mevcut Aranıyor En Son Paket Tipi URL'si
lodash 4.15.0 4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
✨ 1.04s'de yapıldı.