yarn outdated

Verifica se as dependências estão desatualizadas.

yarn outdated

Lista as informações sobre as versões de todas as dependências de um projeto ou pacote. Essas informações incluem a versão instalada atualmente, a versão desejada com base no semver (versionamento semântico) e a versão mais recente disponível.

Por exemplo, suponha que o seu package.json tenha as seguintes dependências listadas:

{
  "dependencies": {
    "underscore": "~1.6.0"
  },
  "devDependencies": {
    "lodash": "4.15.0"
  }
}

A execução do comando deve exibir algo do tipo:

yarn outdated
Package    Current Wanted Latest Package Type    URL
lodash     4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
underscore 1.6.0   1.6.0  1.8.3  dependencies    https://github.com/jashkenas/underscore#readme
✨  Done in 0.72s.
yarn outdated [pacote...]

Lista as informações de versão para uma ou mais dependências de um pacote.

Considerando o arquivo package.json mostrado como exemplo anteriormente, você deve ver o seguinte resultado ao conferir uma das dependências:

yarn outdated lodash
Package Current Wanted Latest Package Type    URL
lodash  4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
✨  Done in 1.04s.