benang upgrade-interaktif

Ini mirip dengan mode pemutakhiran npm-check interactive. Ini menyediakan cara mudah untuk memperbarui paket usang.

` yarn upgrade-interactive [–latest] </ code> </h5>

Perintah upgrade-interactive </ code> mengambil parameter yang sama seperti, dan berfungsi sama dengan perintah upgrade </ code> . Perintah ini akan menampilkan paket usang sebelum melakukan upgrade apapun, yang memungkinkan pengguna untuk memilih paket mana yang akan diupgrade. Yarn akan menghormati rentang versi di package.json </ code> saat menentukan versi untuk ditingkatkan versinya.</p>

Anda bisa memikirkan benang upgrade-interactive </ code> sebagai kombinasi perintah benang usang </ code> dan thread [paket ...] </ code> . Di mana yarn ketinggalan jaman </ code> menampilkan daftar paket usang dan yarn upgrade [paket ...] </ code> kemudian dapat digunakan untuk mengupgrade paket yang diinginkan, yarn upgrade-interactive </ kode> menampilkan daftar paket usang yang sama dan memungkinkan Anda segera memilih yang akan ditingkatkan versinya.</p>

--latest </ code> : Flag ini memberitahu thread untuk mengabaikan rentang versi yang ditentukan di package.json </ code> dan sebagai ganti menggunakan tag code latest </ code> di registri.</p>

[1 /? Pilih paket mana yang akan diupdate. (Tekan & lt; spasi & gt; untuk memilih, & lt; a & gt; untuk mengganti semua, & lt; i & gt; ke pemilihan invers)
  devDependencies ❯ ◯ autoprefixer 6.7.7 ❯ 7.0.0 https://github.com/postcss/ autoprefixer # readme
  ◯ webpack 2.4.1 ❯ 2.5.1 https://github.com/webpack/webpack

  dependencies
  ◯ bull 2.2.6 ❯ 3.0.0-alpha.3 https://github.com/OptimalBits/bull#readme
  ◯ fs-extra 3.0.0 ❯ 3.0.1 https://github.com/jprichardson/node-fs-extra
  ◯ socket.io 1.7.3 ❯ 1.7.4 https://github.com/socketio/socket.io #Baca aku
 ◯ socket.io-client 1.7.3 ❯ 1.7.4 https://github.com/Automattic/socket.io-client#readme
`</pre>