yarn upgrade

Meningkatkan paket yang sudah diinstal ke versi yang terbaru, berdasarkan jarak versi yang ditentukan.

` upgrade yarn [paket | paket @ tag | paket @ versi | @scope /] … [–ignore-engines] [–pattern] </ 0> </h5>

Perintah ini memperbarui dependensi ke versi terbaru mereka berdasarkan rentang versi yang ditentukan di file package.json </ 0> . File yarn.lock </ 0> akan dibuat ulang juga.</p>

Secara opsional, satu atau lebih nama paket dapat ditentukan. Bila nama paket ditentukan, hanya paket yang akan ditingkatkan versinya. Bila tidak ada nama paket yang ditentukan, semua dependensi akan ditingkatkan versinya.

[package]` : When a specified package is only a name then the latest patching version of this package will be upgraded to.</p> ` [package @ tag] </ 0> : Bila paket tertentu berisi tag maka tag yang ditentukan akan ditingkatkan versinya. Tag </ 0> nama dipilih oleh pengelola proyek, biasanya Anda menggunakan perintah ini untuk menginstal pelepasan dukungan eksperimental atau jangka panjang dari paket yang dikembangkan secara aktif. Tag yang Anda pilih akan menjadi versi yang muncul di file package.json </ 0> Anda .</p>

[package @ version] </ 0> : Bila paket tertentu berisi versi maka versi yang ditentukan akan ditingkatkan versinya. The package.json </ 0> ketergantungan referensi juga akan berubah untuk mencocokkan versi tertentu ini. Anda dapat menggunakan nomor atau kisaran versi SemVer </ 0> .</p>

--ignore-engine </ 0> : Flag ini bisa digunakan untuk melewati cek mesin.</p>

Contoh:

yarn upgrade benang upgrade kiri-pad yarn upgrade kiri-pad@ ^1.0.0 yarn upgrade kiri-pad menggerutu yarn upgrade @angular
`</pre> 

` upgrade yarn --pattern  </ 0> akan mengupgrade semua paket yang sesuai dengan pola.</p>

Contoh:

yarn upgrade - tegak tegak yarn upgrade kiri-pad --pattern "gulp | mendengus" yarn upgrade - paling baru --pattern "teguk- (pertandingan yang lebih baru)"
`</pre> 

##### ` upgrade yarn [paket] ... - paling sederhana | -L [--caret | --tilde | --exact] [--pattern] </ 0> </h5>

Paket upgrade upgrade --latest </ 0> sama dengan perintah upgrade </ 0> , namun mengabaikan rentang versi yang ditentukan di package.json </ 0> . Sebagai gantinya, versi yang ditentukan oleh tag terbaru </ 0> akan digunakan (berpotensi meningkatkan paket di seluruh versi utama).</p>

File package.json </ 0> akan diperbarui untuk mencerminkan rentang versi terbaru. Secara default, specifier rentang yang ada di package.json </ 0> akan digunakan kembali jika salah satunya adalah: ^, ~, & lt; =,>, atau versi yang tepat. Jika tidak, itu akan berubah menjadi tanda sisir (^). Salah satu flag --caret </ 0> , --tilde </ 0> atau --exact </ 0> dapat digunakan untuk menentukan rentang secara eksplisit.</p>

Contoh:

yarn upgrade - yarn teranyar meng-upgrade pad kiri - yarn teranyar meng-upgrade gradien kiri - pad --latest --tilde
`</pre> 

##### ` upgrade yarn (--scope | -S) @scope [--latest]  [--pattern] </ 0> </h5>

--scope @ scope / </ 0> : Bila ruang lingkup ditentukan, hanya paket yang dimulai dengan cakupan yang akan ditingkatkan versinya. Lingkup harus dimulai dengan '@'.</p>

- paling lambat </ 0> : Abaikan rentang versi yang ditentukan di package.json </ 0> . Sebagai gantinya, versi yang ditentukan oleh tag terbaru </ 0> akan digunakan (berpotensi meningkatkan paket di seluruh versi utama).</p>

Contoh:

yarn upgrade --scape @angular yarn upgrade -S @angular
`</pre>