yarn ls

Trouve les dépendances obsolètes du paquet.

yarn outdated

Répertorie les informations de version pour toutes les dépendances du package. Ces informations incluent la version actuellement installée, la version désirée basée sur semver et la dernière version disponible.

Par exemple, disons que package.json a les dépendances suivantes répertoriées :

"dependencies": {
  "lodash": "4.15.0",
  "underscore": "~1.6.0"
}

La commande à exécuter doit ressembler à ceci :

yarn ls
Package    Current Wanted Latest Package Type    URL
lodash     4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
underscore 1.6.0   1.6.0  1.8.3  dependencies    https://github.com/jashkenas/underscore#readme
✨  Done in 0.72s.
yarn outdated [package...]

Répertorie les informations de version pour une ou plusieurs dépendances du package.

Pour l’exemple du package.json montré précédemment, vous devriez voir la sortie suivante lors de la vérification d’une des dépendances :

yarn outdated lodash
Package Current Wanted Latest Package Type    URL
lodash  4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
✨  Done in 1.04s.