yarn upgrade-interactive

Esto es similar al modo de actualización interactiva de Mnp-check. Pues proporciona una manera fácil de actualizar los paquetes obsoletos.

actualizacion-interactiva de yarn[--latest]

El comando de actualizacion-interactiva toma los mismos parámetros que, y funciona igual que el comando actualización base. Este comando mostrará los paquetes obsoletos antes de realizar cualquier actualización, permitiendole al usuario seleccionar los paquetes a actualizar. Yarn respetará las gamas de la versión en package.json para determinar la versión a actualizar.

Usted puede pensar de actualización-interactiva de yarn como una combinación de los comandos yarn anticuado y los comando de actualizacion [package...]de yarn. Cuando el yarn anticuado muestra la lista de paquetes anticuados y ` [package…] de actualizacion yarn pueden utilizarse entonces para actualizar los paquetes deseados, actualizacion-interactva de yarn` muestra la misma lista de paquete anticuado y le permite inmediatamente elegir cual actualizar.

--última: esta bandera le indica a yarn ignorar las gamas de la versión especificada en package.json y en cambio usar la versión con la etiqueta más reciente en el registro.

[1/? Elige los paquetes a actualizar. (Presiona <space> para seleccionar, <a> apalancarlos a todos, <i> a elecciones inversas)
Dependencias de desarrollador
❯◯ autoprefixer      6.7.7  ❯  7.0.0          https://github.com/postcss/autoprefixer#readme
 ◯ webpack           2.4.1  ❯  2.5.1          https://github.com/webpack/webpack

 dependencias
 ◯ bull              2.2.6  ❯  3.0.0-alpha.3  https://github.com/OptimalBits/bull#readme
 ◯ fs-extra          3.0.0  ❯  3.0.1          https://github.com/jprichardson/node-fs-extra
 ◯ socket.io         1.7.3  ❯  1.7.4          https://github.com/socketio/socket.io#readme
 ◯ socket.io-client  1.7.3  ❯  1.7.4          https://github.com/Automattic/socket.io-client#readme
Lectura Adicional