yarn outdated

Comprueba las dependencias de paquetes obsoletos.

yarn outdated

Muestra información de versión para todas las dependencias del paquete. Esta información incluye la versión instalada actualmente, la versión deseada basada en semver y la última versión disponible.

Por ejemplo, digamos que tu package.json tiene las siguientes dependencias enumeradas:

{
  "dependencies": {
    "underscore": "~1.6.0"
  },
  "devDependencies": {
    "lodash": "4.15.0"
  }
}

El comando a ejecutar deberia verse algo como esto:

yarn outdated
Package    Current Wanted Latest Package Type    URL
lodash     4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
underscore 1.6.0   1.6.0  1.8.3  dependencies    https://github.com/jashkenas/underscore#readme
✨  Done in 0.72s.
yarn outdated [package...]

Muestra información de versión para una o más dependencias del paquete.

Para el ejemplo package.json que se muestra anteriormente, veremos el siguiente resultado al comprobar una de las dependencias:

yarn outdated lodash
Package Current Wanted Latest Package Type    URL
lodash  4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
✨  Done in 1.04s.